Free Shipping on ALL Products
camera reviewsbest cameraslens reviewsphotography tipscamera forumvideo toursphotography bookssupport me
It is currently Sun Nov 23, 2014 12:03 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Wed Oct 14, 2009 2:14 am 
Hi, reading Gordon's article about the sound setup he did I tried to get the Steve Monks plug to work for me in order to hear the difference, but I am having troubles.
This is my hardware setup:
WinXP on a q6600 4GB PC.
Audiophile USB external sound card (this is essentially the same card as 2496 except its not PCI card)
Analog output from this card goes to M-Audio's StudioPro3 stereo speaker set (small semi-pro studio monitors).


Software:
Freshly installed Winamp 5.56 on a freshly installed WinXP.
New drivers from M-Audio.

When I go to Plug-ins/Output and choose Kernel Streaming Output 3.63 and reset the player, I cant get Winamp to deliver the sound. If I go to configure on this plug and choose Audiophile Out 1/2 as my output device, then on next restart Winamp would freeze and of course wouldnt play the file.
These are just normal mp3 files.


Top
  
 
 Post subject:
PostPosted: Wed Oct 14, 2009 6:22 pm 
Hi.

Although I'm not familiar with your sound card, there are, off the top of my head, a few reasons why the plugin may not be working for you.

The first and most obvious one is exclusivity. The Kernel Streaming plugin requires exclusive access to the sound card which it will not be able to get if some other application has requested access to it. I've seen this sort of thing happen when I've had web browsers open with embedded video players or flash games with audio before trying to play something in Winamp. The only solution here is to close the browser (or sometimes browse away to an audio free page) then restart Winamp noting that, when it's frozen like this you need to kill off its process in the task manager before it will correctly restart.

Secondly, I've had issues with certain revisions of M-Audio drivers, oddly enough, more recent versions that refuse to work with the plugin. The driver reports back quite happily to the plugin, but when I start sending data to it, it just refuses to play. It may be worth trying some older versions of the driver to see if they work.

Thirdly, some cards don't correctly handle all of the sample frequencies you might expect via KS, it would be interesting to know if the plugin can play 48KHz samples via this card.

Finally, I've previously had problems using a Cambridge Audio DacMagic via USB. After a bit of investigation, this turned out to be based on a widely used C-Media USB interface where the standard generic Microsoft drivers didn't support KS. In the end I think I tracked down and installed a generic C-Media driver for it that did support KS, it could be that your card uses the same chipset to provide the USB interface, although, as I said earlier, I'm unfamiliar with your sound card, so this is purely speculation on my part.

I did have a quick Google around for a solution and found this thread which seems to be about this very problem with your sound card, although, for some strange reason I can only see the M-Audio side of the conversation, all of the other posts are blank;

http://forums.m-audio.com/showthread.php?t=8575

From their engineering response, it does look like KS isn't supported on this card, although their support guy states that none of their products support KS, which we know isn't exactly the case.

You can get the plugin to generate a log file by turning on logging in its configuration panel, the log can be found in the Winamp installation folder and is called "kernel streaming log.txt". If you try to play a file via KS then send me the log it generates I'll take a look to see if it reports anything useful that may shed some light on the problem.

Let me know how you get on.

Steve


Top
  
 
 Post subject:
PostPosted: Wed Oct 14, 2009 9:09 pm 
Offline
Moderator
User avatar

Joined: Sun Nov 05, 2006 11:08 pm
Posts: 7968
Location: Germany
Hello Steve, and welcome to the friendly Camera Labs forum!
To enjoy your stay here please have a look at the house-rules!
----
Nice you're here to help people with your plug-in.
Thanks a heap!

_________________
Thomas (beware: Nikon-fanboy and moderator!) My Lens Reviews, My Pictures, My Photography Blog
D800+assorted lenses


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 14, 2009 9:53 pm 
Great, Steve himself.

I will certainly do this once when I get home. If I am not mistaken when I was looking for a good sound card I remember reading about my USB card and 2496 being the same in terms of everything except of the way it plugs in the computer.

Later once when I exhaust every option with Steve's plugin I tried to get the winamp to play through M-Audio USB ASIO driver and that didnt turn good either, and then I tried the ASIO4ALL and had way more success.

Also I download the Foobar2k for the first time and got it to run with M-Audio USB ASIO driver but it didnt last long and then I configured it for ASIO4ALL and it was quite happy for the rest of the night.


Top
  
 
 Post subject:
PostPosted: Wed Oct 14, 2009 10:00 pm 
and another thing I remember was that I was not able to make volume adjustment by Windows mixer (in the old drivers) and now I checked and it works.

I remember asking the M-Audio that question since that was my first time to see some hardware bypassing the built in mixer and support told me this was way how their card worked.

I was little bit suprised but I got used to it.

Then for the longest time I havent used this card and in last year when I did I found out that Windows have control over the volume power.


Top
  
 
 Post subject:
PostPosted: Thu Oct 15, 2009 1:09 am 
Offline
Site Admin
User avatar

Joined: Tue Nov 08, 2005 3:32 pm
Posts: 9975
Location: Queenstown, New Zealand
Thanks for posting Steve - and welcome on-board!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All words, images, videos and layout, copyright 2005-2012 Gordon Laing. May not be used without permission.
/ How we test / Best Cameras / Advertising / Camera reviews / Supporting Camera Labs

Webdesign by Alphabase IT
Powered by phpBB® Forum Software © phpBB Group