Free Shipping on ALL Products
camera reviewsbest cameraslens reviewsphotography tipscamera forumvideo toursphotography bookssupport me
It is currently Thu Jul 24, 2014 11:54 am

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Flash Prob
PostPosted: Sat Apr 11, 2009 8:13 pm 
Hello I've baught an external flash from ebay that is not from Olympus. The problem I'm havig with it is that when I set the camera to Program mode and use it in low light the camera does not recognise it, in fact when I press the shutter release half way the camera set the shutter speed to 2secs automatically! Is there any setting that I'm missing?

P.S.
This problem does not occur when I use Shutter Priorty mode only!


Top
  
 
 Post subject:
PostPosted: Sun Apr 12, 2009 5:23 am 
Is the flash supposed to be fully compatible with the E-520?


Top
  
 
 Post subject:
PostPosted: Sun Apr 12, 2009 6:16 am 
When I've asked the seller of ebay he told me that is is fully compatible with the E-520 in fact he had flash for Canon & Nikon etc and I obviosly choose the one compatible with my camera!


Top
  
 
 Post subject:
PostPosted: Sun Apr 12, 2009 7:31 pm 
That's a stinker ... Sorry, I know less about flash than even the little that I know about cameras. I have the FL36R, and I don't even know how to use all the features on it yet.


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All words, images, videos and layout, copyright 2005-2012 Gordon Laing. May not be used without permission.
/ How we test / Best Cameras / Advertising / Camera reviews / Supporting Camera Labs

Webdesign by Alphabase IT
Powered by phpBB® Forum Software © phpBB Group