Free Shipping on ALL Products
camera reviewsbest cameraslens reviewsphotography tipscamera forumvideo toursphotography bookssupport me
It is currently Sun Nov 23, 2014 12:28 pm

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Wed Aug 19, 2009 1:48 pm 
I've been having hideously slow performance in Photoshop CS4 when using the brush and other features. After unsuccessfully trying to Google my way through my problem and trying out what worked for other people I stumbled across my solution. Someone suggested turning off OpenGL in Photoshop CS4.

Instead of completely turning off OpenGL I first tried just turning off vertical sync and voila! Silky performance as smooth as a newborn's butt!! To get there simply go under Edit > Performance > Click on the OpenGL options. In there I only turned off Vertical Sync which was enabled by default. The difference is night and day, its buttery smooth now.

Now every computer is different but its worth a try if you are having poor performance. You can also try totally turning off OpenGL also.

Hope this will turnout useful for someone out there.

Oh btw my computer is a Dell Studio XPS 16, Intel Core2Duo 2.66ghz, 4GB DDR3, ATI Radeon Mobile 3670 512MB, etc.


Top
  
 
 Post subject:
PostPosted: Wed Aug 19, 2009 1:53 pm 
Interesting.....you shouldn't have to turn anything off though. Have you tried updating your drivers?


Top
  
 
 Post subject:
PostPosted: Wed Aug 19, 2009 9:29 pm 
Offline
User avatar

Joined: Sun Feb 15, 2009 12:59 pm
Posts: 6009
Location: The Netherlands
Vertical sync is for matching frames per second with the refresh rate of your monitor. It impacts the maximum pre-rendered frames though, so it does have a small performance hit, but for photoshop...?

_________________
I take pictures so quickly, my highschool was "Continuous High".


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 19, 2009 11:49 pm 
I'm a really big techie and keep all my drivers up to date. I do realize that vertical sync is used to sync the frame per second rendering with the monitor's refresh rate so in theory it shouldn't have any noticeable difference. However like all software there are bugs and in my case the OpenGL's Vertical Sync is severely bugged causing the frame rate to plummet do the basement. The vertical sync was turned off inside Photoshop's own preference setting.


Top
  
 
 Post subject:
PostPosted: Thu Aug 20, 2009 9:43 am 
Offline
User avatar

Joined: Sun Feb 15, 2009 12:59 pm
Posts: 6009
Location: The Netherlands
Okay, still very interesting. Possibly a bug in ATI's driver? (I've had nothing but bad experiences with ATI drivers)

_________________
I take pictures so quickly, my highschool was "Continuous High".


Top
 Profile  
 
 Post subject:
PostPosted: Thu Aug 20, 2009 11:08 am 
I use Ati drivers myself and have had no problems at all with OpenGL on any program
on this Psee, this includes Adobe photoshop, lightroom and CS3. It's possible it's something
else conflicting with the Ati drivers or bad instal/update.


Top
  
 
 Post subject:
PostPosted: Thu Aug 20, 2009 12:21 pm 
Keep in mind I have to use the Dell supplied ATI Driver for the mobile GPU and not the regular Catalyst drivers so it isn't updated as frequently as the desktop GPUs. The regular Catalyst drivers off ATI's website wont work with this mobile GPU.

I also have Lightroom2 which works brilliantly.

Lastly I'm also running Vista 64bit and CS4 64bit.

Back home I use ATI or Nvidia GPUs on my desktop without any issues. I don't necessary prefer one or the other, I simply get the best card out at the time. However currently I'm running ATI's on both my laptop and desktop.


Top
  
 
PostPosted: Thu Aug 20, 2009 8:47 pm 
elro wrote:
I've been having hideously slow performance in Photoshop CS4 when using the brush and other features. After unsuccessfully trying to Google my way through my problem and trying out what worked for other people I stumbled across my solution. Someone suggested turning off OpenGL in Photoshop CS4.

Instead of completely turning off OpenGL I first tried just turning off vertical sync and voila! Silky performance as smooth as a newborn's butt!! To get there simply go under Edit > Performance > Click on the OpenGL options. In there I only turned off Vertical Sync which was enabled by default. The difference is night and day, its buttery smooth now.

Now every computer is different but its worth a try if you are having poor performance. You can also try totally turning off OpenGL also.

Hope this will turnout useful for someone out there.

Oh btw my computer is a Dell Studio XPS 16, Intel Core2Duo 2.66ghz, 4GB DDR3, ATI Radeon Mobile 3670 512MB, etc.


I'm on an amd X2 4600, with an 8800gtx and 2gb ram, running open GL and I havent got any problems.


Top
  
 
 Post subject:
PostPosted: Sat Aug 22, 2009 6:14 am 
Oh I'm sure that the OpenGL feature works as intended for most people. However when we are talking about software it will never work perfectly for everyone. There are always conflicts and problems that arises for a few who are unfortunate.

I will just pointing out one possible cause of slow performance in CS4 or another "fix" to try out if you are having problems with poor frame rates when using the adjustment brush.


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All words, images, videos and layout, copyright 2005-2012 Gordon Laing. May not be used without permission.
/ How we test / Best Cameras / Advertising / Camera reviews / Supporting Camera Labs

Webdesign by Alphabase IT
Powered by phpBB® Forum Software © phpBB Group