Free Shipping on ALL Products
camera reviewsbest cameraslens reviewsphotography tipscamera forumvideo toursphotography bookssupport me
It is currently Sun Jan 22, 2017 12:53 pm

All times are UTC

Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Tue Jan 06, 2009 5:15 am 
Just got my copies of CS4 (Mac) and Lightroom today. Lightroom 2.0 installed without troubles. Upgraded it to version 2.2. But after installing CS4 I didn't see the "blue PS folder" icon. Instead I got a white/yellow "papers w/ circle on top of the papers...w/ a diagonal slash across the circle.

Days before I had the trial copy of CS4 Extended installed. Removed that days ago anticipating my copy of CS4 (and Lightroom).

I've used app delete programs like "appdelete" and "appzapper". The first program found 3 files and the second porgram found 2. No luck after installing CS4 a second time. Same thing. Same "cannot run" icon.

The error message goes as follows...

...You can't open the application "Adobe Photoshop CS4" because it is not supported on this architecture...

Why is it I had no troubles installing Lightroom 2.0 then?

I've Googled. Tried different things. No luck so far. So if any Mac guru's out there can help me? CS4 experts?? :)

 Post subject:
PostPosted: Tue Jan 06, 2009 8:42 pm 
Site Admin
User avatar

Joined: Tue Nov 08, 2005 3:32 pm
Posts: 9978
Location: Queenstown, New Zealand
I can't help on the Mac front I'm afraid, but if it's complaining about an architecture issue, it sounds like it's tried to install, say, an Intel version on a non Intel platform. Or as you suspect, maybe something's been left behind from the previous installation that's conflicting with it.

I hope one of our Mac members can help... On the Mac front, I only have a pre-Intel Mini for checking browser compatibility, so I'm not much use to you...

The Adobe forums would also be a good bet...

 Post subject:
PostPosted: Tue Jan 06, 2009 10:34 pm 
User avatar

Joined: Sat Feb 09, 2008 9:06 am
Posts: 389
Location: Manchester (UK)
This is what is listed on Adobe site.... you have 20 seconds to comply ;-)

PowerPC® G5 or multicore Intel® processor
Mac OS X v10.4.11–10.5.4
512MB of RAM (1GB recommended)
2GB of available hard-disk space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on flash-based storage devices)
1,024x768 display (1,280x800 recommended) with 16-bit video card
Some GPU-accelerated features require graphics support for Shader Model 3.0 and OpenGL 2.0
DVD-ROM drive
QuickTime 7.2 software required for multimedia features
Broadband Internet connection required for online services*

Canon EOS 400D, EF-S 18-55mm, EF 24-105mm f/4L IS USM, EF 50mm f/1.8 MK I, EF-S 10-22mm, EF 70-200mm f/4L IS USM, EF 35mm f/2 IS USM, EF 85mm f/1.8 USM, EF 135 f/2L USM
Canon 430EX II, Manfrotto 055CXPRO3, Arca Swiss P0
Panasonic GX1, Panasonic 20mm f/1.7, Olympus 45mm f/1.8
Canon EOS 30/33 and Pentax MX/ME Super
Rollei 35S


 Post subject:
PostPosted: Tue Jan 06, 2009 10:36 pm 
Hello Gordon,

No. It's not referring to the hardware architecture but the software.

I solved the problem last night any how. Thank God!! Was afraid I'd have to reformat my HD on my Apple MBP. Last resort always.

Any how I ended up downloading the trial version of CS4 Extended. Then, I read the READ.ME file (should always be read). Which stressed that when removing an Adobe app like CS4 you MUST use the supplied Adobe Uninstall program. You cannot (or should not) just drag the CS4 folder to the TRASH icon (nor drag it to an app deletion program).

Installed my copy of CS4. No problems. And got the 6 tab SETUP dialogue box. Previously when I had bits of the other version of CS4 installed (Extended) I only got the SETUP dialogue box with 3 tabs.

Install went without a hitch and the programs run fine. Done!!

Hope this will help any one else (Mac users) who run into this problem.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC

Who is online

Users browsing this forum: Google [Bot] and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All words, images, videos and layout, copyright 2005-2012 Gordon Laing. May not be used without permission.
/ How we test / Best Cameras / Advertising / Camera reviews / Supporting Camera Labs

Webdesign by Alphabase IT
Powered by phpBB® Forum Software © phpBB Group