Free Shipping on ALL Products
camera reviewsbest cameraslens reviewsphotography tipscamera forumvideo toursphotography bookssupport me
It is currently Fri Jan 20, 2017 8:01 am

All times are UTC

Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Sat May 09, 2009 1:54 am 
I've had my Canon for 5 months. My memory card has worked just fine and i've had no problems with it. A couple of days ago I put my memory card in and it tells me the card needs formatting. I try to format it but it just says cannot format. change card. So, I format it on my PC instead and erase the images (they're saved to my pc now). I put the card back into the camera and the same thing keeps happening. I click okay to format and it just says "cannot format. change card." I've tried 3 of my memory cards and all 3 are doing this but these cards work in my daughter's little digital camera so it's not the cards. I still double checked to make sure there wasn't anything bent or out of line on the cards and they're perfect. Can anyone please please tell me a way to fix this? I'm trying to avoid sending my camera in if possible because I'm needing it in about 2 weeks for my son's graduation and i'm afraid the camera won't be back. I have no idea how long it takes them to fix it but I'd be eternally grateful to anyone who could help me figure out how to fix this problem without me having to send it off. Any suggestions? Anyone with experience with this issue? :?:

 Post subject:
PostPosted: Sat May 09, 2009 9:52 am 
User avatar

Joined: Sat Sep 30, 2006 4:30 pm
Posts: 9886
Location: UK
Hi missmandy,

May I offer you a warm welcome to the CameraLabs forum.

That's bad luck and dreadful timing. I've not seen this and I'm no expert but it sounds as though the card reader in the camera may be at fault, possibly with a bent pin. If that's so I see no option but to send the camera in for repair as, and I proved this to myself pretty disastrously a few years back with a card reader on my printer, trying to straighten a bent pin is a very risky procedure. :oops: But maybe SD card readers are more forgiving than CF readers in that regard? :?

The only easy thing I can think of for you to try is to remove the camera's battery for a few seconds just in case this is a software glitch in the camera.

Failing any better suggestions on how to fix the problem from other members I see no option but to have the camera repaired. Can you borrow another Canon DSLR from a friend for the graduation? Another possibility would be to hire a camera but that's an expensive way to go unfortunately. Fingers crossed that you find a solution in time for the big day.


Sony RX1R II. Olympus OM-D E-M1 + M.Zuiko Digital ED 12-40mm f/2.8, M.Zuiko Digital ED 40-150mm f/2.8 + 1.4x T/C, Lumix 7-14mm f/4, Leica DG Summilux 15mm f/1.7 ASPH, M.Zuiko Digital 45mm 1:1.8
M.Zuiko Digital ED 75mm 1:1.8, Leica D Vario-Elmar 14mm-150mm f/3.5 - f/5.6 ASPH.
OM-D E-M5, H-PS14042E, Gitzo GT1541T, Arca-Swiss Z1 DP ball-head.
Astrophotography: TEC 140 'scope, FLI ML16803 camera, ASA DDM60 Pro mount.

 Post subject:
PostPosted: Sun May 10, 2009 9:16 am 
I am no expert but have you tried to erase the images from the card instead of formatting like it wants you too?

I would try erasing all images on the camera and then trying to format it.

I hope it is ready in time.

 Post subject:
PostPosted: Sun May 10, 2009 9:36 am 
User avatar

Joined: Sat Jan 24, 2009 12:58 am
Posts: 285
Location: Germany
Don't have a real clue for a solution, but I wondered if the said card was used also in your daughter's camera before the incident.

Maybe your Canon doesn't like cards that were in use in other cameras as well and you shouldn't switch them because other cameras might have a different filing system than your Canon.

Just a guess.


 Post subject:
PostPosted: Sun May 10, 2009 8:53 pm 
HTG, they've reformatted the card so that point is moot, and my XS didn't seem to hate me putting in the card i used with my sanyo camera.

PostPosted: Mon May 11, 2009 7:45 am 
Dude, I just got my camera as a grad gift, and it won't format at all, no matter what card is put in; they work on other cameras. nothing has worked. [/i]

PostPosted: Mon May 11, 2009 8:20 am 
floydthebarber2 wrote:
Dude, I just got my camera as a grad gift, and it won't format at all, no matter what card is put in; they work on other cameras. nothing has worked. [/i]

what happens when you try?

 Post subject: Re:
PostPosted: Mon May 11, 2009 7:36 pm 
Cannot format. Change card.
If it'd at least state why it won't, it'd make things a lil easier...i mean, it's just out of the box.

 Post subject: follow up
PostPosted: Wed May 13, 2009 12:32 pm 
I appreicate everyone's reply. In response to the suggestion to erase the images from the card: I did go ahead and erase them all and tried everything the Canon technician could suggest to no avail. So, I finally sent it in to be fixed by Canon. I'll let you know how it works out. I think the card reader must be malfunctioning or broken and that's what they seem to think too....although that's kinda obvious due to the problems :) lol

 Post subject: 2nd time for me
PostPosted: Sun Mar 07, 2010 5:58 am 
This same problem has occurred to me twice (just recently). I'll have to call this week since the warranty expires on 3/22. Thankfully, I have another Canon Rebel XS this has never occurred with (I had to get a 2nd unit since I was leaving for my Alaska trip and didn't want to be without a camera for one of my bucket item trips). The first time they "repaired" the unit I got a cryptic response sheet from the repair center in Canada that seemed to implied I didn't know how to insert an SD card and they cleaned the unit, updated the firmware, and did a general reset. It seemed to work for a while, but is now doing the same thing. Sigh...

 Post subject:
PostPosted: Sun Mar 07, 2010 11:20 am 
I think the general problem you all might be suffering from is to do with the card formatting, and in particular the file format system the cards are beinging formatted/re-formatted with i.e. Fat16, Fat32, etc.

Try re-formatting to a different file system. If nothing else it might allow your camera to re-format the cards itself to what it wants to use.

My father-in-law recently had this problem with a CF card he was given to use in his little digicam. Wouldn't work or re-format in-camera, but worked fine in all five of my CF-using cameras

I did just this, re-formatted it to a different file system via a computer, and then it worked fine. And just to prevent any more problems he re-formatted it in the camera. No more problems since.

Using the same card in different devices might be an issue if they automatically re-format it when inserted, and the formats conflict. Older cameras use Fat16, newer ones Fat32.

PostPosted: Sat Dec 15, 2012 3:15 am 
***Temp Solution Found***
My rebel is having the same issue. My XT never had these issues with CF cards. I've tried formatting the card in my Mac and PC to no avail. Pulled out the battery for a few seconds with the camera off and again with the camera on, but no luck.

Finally I believe I found the issues. The reader contacts are dirty. I took the card and pushed it in and out about 15 times in rapid succession (with the camera off of course). Now it works again. I've pulled the card out and put it back in a few times and it likes the card again. My camera is well out of warranty now. I'm going to open it and clean the contacts with some Isopropyl Alcohol.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All words, images, videos and layout, copyright 2005-2012 Gordon Laing. May not be used without permission.
/ How we test / Best Cameras / Advertising / Camera reviews / Supporting Camera Labs

Webdesign by Alphabase IT
Powered by phpBB® Forum Software © phpBB Group