Free Shipping on ALL Products
camera reviewsbest cameraslens reviewsphotography tipscamera forumvideo toursphotography bookssupport me
It is currently Sat Sep 20, 2014 8:02 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Nov 05, 2010 8:50 am 
Hi guys,

I'm relatively new the SLR game. I recently bought a Canon 550D with the kit 18-55. I soon found that this wasnt good enough, so I got myself a Sigma 17-70mm f2.8-4 OS HSM lens. However, I am having trouble with the auto focus. It seems to take the camera a while to autofocus when I am zoomed at 70mm.

The object is a good half a metre away, and I've set the focus point to the centre, but most of the time it just twitches and cant seem to focus. Although the problem is much reduced when at 17mm

At first I thought it was my lens filter, but I took that off and it still had the same problem

Can anyone tell me what the problem is? Is it the camera lens setting in because it's new? is that how it's meant to be? Is the lens faulty? I'm really hoping it's not faulty because I leave for Europe in 2 weeks and I doubt Sigma will have it fixed/replaced by then

Thanks for your time
jz


Top
  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 5:04 pm 
Hi jetz427,

and welcome to the forum!!

Without trying it hands-on, it's difficult to be certain. But if I'm going with what you say, and "most of the time it just twitches and can't seem to focus", then chances are that the lens is faulty.

Auto-focus is a collaboration between the camera and the lens. Everyone has occasional trouble with AF under certain circumstances - for example in low light and in low-contrast settings. Under such circumstances it's not uncommon to have to try a few times to get it right. But it is usually possible to resolve.

Your lens has a minimum focus distance of 22cm - if you go below that, don't expect it to be able to auto-focus. But you are saying that AF works well at shorter ranges, so that is probably not your challenge.

Sigma produce excellent lenses at very competitive prices. But one of the reasons why they haven't taken over the market is their occasionally faulty quality assurance. Many members here have ha to send back Sigma lenses for adjustments more than once! But when they work as intended, they offer great performance at a really good price.

If you have purchased this lens at a reputable dealer, they should be willing to replace it with another sample instantly, while they send your sample back to Sigma.

Good luck - I hope you get it resolved before your trip!

Cheers :-)


Top
  
 
 Post subject:
PostPosted: Fri Nov 05, 2010 6:16 pm 
Offline

Joined: Mon Jan 18, 2010 3:52 pm
Posts: 2175
Location: The Netherlands
Maybe the electronics are dirty?

_________________
Ruben

Panasonic DMC-FZ18, Panasonic DMC-FZ28, Canon G5, Canon 350D, Canon 50D + BG-E2N
Tamron 17-50 2.8, Canon EF 70-200mm f/4L USM,
Canon 18-55 II plus lots of Minolta MD/M42 lenses and bodies


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 08, 2010 9:21 pm 
Offline
User avatar

Joined: Sun Feb 15, 2009 12:59 pm
Posts: 6009
Location: The Netherlands
What are you focusing on? The AF system needs something contrasty, and well-lit to work properly.

_________________
I take pictures so quickly, my highschool was "Continuous High".


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 29, 2010 7:58 am 
i agree, you may be focusing on something with not enough contrast or in a too dark environment.. if it's a person, always focus on the eyes.


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: Thomas and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  

All words, images, videos and layout, copyright 2005-2012 Gordon Laing. May not be used without permission.
/ How we test / Best Cameras / Advertising / Camera reviews / Supporting Camera Labs

Webdesign by Alphabase IT
Powered by phpBB® Forum Software © phpBB Group